birds like wires

Search

Running pfSense on a Mac Pro

I’m a big fan of pfSense. If you’ve not heard of it, it’s an open source firewall that’s got more options that you can shake a stick at, but most importantly, is as solid as a rock and takes about a second to back up.

I’d been running it as a virtual machine on a couple of servers, but with a recent round of hardware changes I found myself with a 2006 vintage Mac Pro with no job to do. True, it’s massively overpowered for the job, but it’s got two good gigabit Intel NICs built-in and would make the VM setup, which I never liked, redundant. Plus, it would otherwise be sat on the floor doing nothing.

Setup

It’s trivial; I prepped the Mac with a single 80GB hard drive and zapped the PRAM just to be on the safe side (CMD-ALT-P-R). Then I burned the AMD64 image to a disc, booted the Mac with ALT held down and chose the ‘Windows’ CD. It’s obviously not Windows; that’s just what the Mac is programmed to title boot devices that aren’t OS X.

From there it’s just a case of choosing the installer when prompted and telling it to do a ‘Quick / Easy Install’. Everything from there is handled by pfSense, except for removing the CD (hold down the left mouse button to force a CD eject on reboot). Very easy.

One Hiccup

You need some work to do, so here it is. For reasons unknown the Mac’s ACPI system reports that it has a battery. It doesn’t, or at least not one I know about, but it upsets FreeBSD because it tries to find it, spamming the kernel log with this as it goes:

kernel: acpi_smbus_read_2: AE_ERROR 0x10

To fix it, add the following line to /boot/loader.conf:

debug.acpi.disabled="smbat"

Then reboot. All error messages are now banished!

Configuration Tips

One thing that’s handy and not immediately obvious is enabling monitoring of the thermal sensors on the processors. I’ve not tried to enable the plethora of other sensors available on the Mac Pro, but to get the on-die ones working, just go to System > Advanced > Miscellaneous and choose ‘Intel Core CPU on-die thermal sensor’. Not all Xeon chips have these, if I remember correctly, but the Xeon 5150 chips in this 2006 model certainly do.

I mentioned that quick backup too; just go to Diagnostics > Backup/Restore and hit the ‘Download configuration’ button. That’s about it!

I found your post when googling a problem I’m having. I’m also trying to run pfSense on a Mac Pro 2006 (mac1,1). I can boot from the CD, but when I select “Boot Multiuser” it starts to boot but always panics. It seems to happen after initializing firewire, at least that are the last messages on the console before the trap.

Did you do something special to work around that or did you not encounter that? I’m using pfSense 2.2.6, what version were you using?

Einar Bjarni left this message 599 days ago

@Einar Bjarni That sounds annoying; I think was using one of the 2.2.x versions, but I honestly can’t remember now. You could give an earlier version a try and see if you get any further. I’m certain one of my test boxes was on 2.0.2, so I’d give that one a whirl to start with.

Andy left this message 599 days ago